aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2020-07-10 01:24:55 +0300
committerGitHub <noreply@github.com>2020-07-10 01:24:55 +0300
commit0210a43196611c7c9216e923e3e11c6fe1b98876 (patch)
treeef344c18000e6c9dc99668a58f4c56dce76221e8 /alacritty/Cargo.toml
parent46c0f352c40ecb68653421cb178a297acaf00c6d (diff)
downloadr-alacritty-0210a43196611c7c9216e923e3e11c6fe1b98876.tar.gz
r-alacritty-0210a43196611c7c9216e923e3e11c6fe1b98876.tar.bz2
r-alacritty-0210a43196611c7c9216e923e3e11c6fe1b98876.zip
Fail compilation if Fontconfig is not installed on Linux/BSD
Statically linking Fontconfig was leading to slow startup and various errors, so forcing the use of system's library.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index 62942985..6cd63867 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -20,7 +20,7 @@ serde_json = "1"
glutin = { version = "0.24.0", features = ["serde"] }
notify = "4"
parking_lot = "0.10.2"
-font = { path = "../font" }
+font = { path = "../font", features = ["force_system_fontconfig"] }
urlocator = "0.1.3"
copypasta = { version = "0.7.0", default-features = false }
unicode-width = "0.1"