aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2020-12-20 07:57:03 +0000
committerGitHub <noreply@github.com>2020-12-20 07:57:03 +0000
commit37a3198d8882463c9873011c1d18c325ea46d7c8 (patch)
tree85ffd2da842823109fc50ce9b41c5c109e71068f /alacritty/Cargo.toml
parentf016a209b4ac1bfa6625b9d30e6f69bc91bc7545 (diff)
downloadr-alacritty-37a3198d8882463c9873011c1d18c325ea46d7c8.tar.gz
r-alacritty-37a3198d8882463c9873011c1d18c325ea46d7c8.tar.bz2
r-alacritty-37a3198d8882463c9873011c1d18c325ea46d7c8.zip
Fix embedded _NET_WM_ICON on X11
Previously the _NET_WM_ICON would use the .ico which was also used for the Windows icon. This icon used the dimensions 256x256, but the maximum supported image size is 192x192, so a new image with the dimensions 64x64 has been added. Since we know the image format anyways, the `image` dependency could also be easily replaced with `png`, which cuts out a few extra unused dependencies.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index a4f774b1..b5ebefe2 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -39,7 +39,7 @@ gl_generator = "0.14.0"
xdg = "2"
[target.'cfg(not(target_os = "macos"))'.dependencies]
-image = { version = "0.23.3", default-features = false, features = ["ico"], optional = true }
+png = { version = "0.16.8", default-features = false, optional = true }
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"
@@ -56,7 +56,7 @@ embed-resource = "1.3"
[features]
default = ["wayland", "x11"]
-x11 = ["copypasta/x11", "glutin/x11", "x11-dl", "image"]
+x11 = ["copypasta/x11", "glutin/x11", "x11-dl", "png"]
wayland = ["copypasta/wayland", "glutin/wayland", "wayland-client"]
winpty = ["alacritty_terminal/winpty"]
nightly = []