aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2020-10-12 12:22:36 +0300
committerGitHub <noreply@github.com>2020-10-12 12:22:36 +0300
commit721f789b5f98ab5c47e6e817c3c2228636ca0a1a (patch)
tree31d9a149fbcf36c9a824856d1da103c06f67f16c /alacritty/Cargo.toml
parent56e0f5bb05cab709f815ef9cce027b379ce964b8 (diff)
downloadr-alacritty-721f789b5f98ab5c47e6e817c3c2228636ca0a1a.tar.gz
r-alacritty-721f789b5f98ab5c47e6e817c3c2228636ca0a1a.tar.bz2
r-alacritty-721f789b5f98ab5c47e6e817c3c2228636ca0a1a.zip
Make use of glutin wayland/x11 features
This should allow users that are not using Wayland/X11 to reduce the resulted binary size and compilation times.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index 1bacd0cf..a8ae5196 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -21,7 +21,7 @@ fnv = "1"
serde = { version = "1", features = ["derive"] }
serde_yaml = "0.8"
serde_json = "1"
-glutin = { version = "0.25.0", features = ["serde"] }
+glutin = { version = "0.25.1", default-features = false, features = ["serde"] }
notify = "4"
parking_lot = "0.11.0"
crossfont = { version = "0.1.0", features = ["force_system_fontconfig"] }
@@ -47,8 +47,8 @@ objc = "0.2.2"
dirs = "2.0.2"
[target.'cfg(not(any(target_os="windows", target_os="macos")))'.dependencies]
-x11-dl = "2"
-wayland-client = { version = "0.28.0", features = ["dlopen"] }
+x11-dl = { version = "2", optional = true }
+wayland-client = { version = "0.28.0", features = ["dlopen"], optional = true }
[target.'cfg(windows)'.dependencies]
winapi = { version = "0.3.7", features = ["impl-default", "wincon"]}
@@ -58,8 +58,8 @@ embed-resource = "1.3"
[features]
default = ["wayland", "x11", "winpty"]
-x11 = ["copypasta/x11"]
-wayland = ["copypasta/wayland"]
+x11 = ["copypasta/x11", "glutin/x11", "x11-dl"]
+wayland = ["copypasta/wayland", "glutin/wayland", "wayland-client"]
winpty = ["alacritty_terminal/winpty"]
# Enabling this feature makes shaders automatically reload when changed
live-shader-reload = []