aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2020-11-14 21:10:26 +0300
committerGitHub <noreply@github.com>2020-11-14 21:10:26 +0300
commit9531e661b1cf777fc24d011e6116a501bd1b75e5 (patch)
tree5eb7f289690f5cc0ae572a985aeaf1f8206c7f60 /alacritty/Cargo.toml
parentc63bdf5cb966a5dd0afa3ed0327efca691abf504 (diff)
downloadr-alacritty-9531e661b1cf777fc24d011e6116a501bd1b75e5.tar.gz
r-alacritty-9531e661b1cf777fc24d011e6116a501bd1b75e5.tar.bz2
r-alacritty-9531e661b1cf777fc24d011e6116a501bd1b75e5.zip
Feature gate 'image' when building without x11 feature
On Wayland there's no way to embed icon into the window, thus there's no point in loading it when x11 feature is disabled.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index 873c3da6..7a56f90c 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -37,7 +37,7 @@ gl_generator = "0.14.0"
xdg = "2"
[target.'cfg(not(target_os = "macos"))'.dependencies]
-image = { version = "0.23.3", default-features = false, features = ["ico"] }
+image = { version = "0.23.3", default-features = false, features = ["ico"], optional = true }
[target.'cfg(target_os = "macos")'.dependencies]
objc = "0.2.2"
@@ -57,7 +57,7 @@ embed-resource = "1.3"
[features]
default = ["wayland", "x11"]
-x11 = ["copypasta/x11", "glutin/x11", "x11-dl"]
+x11 = ["copypasta/x11", "glutin/x11", "x11-dl", "image"]
wayland = ["copypasta/wayland", "glutin/wayland", "wayland-client"]
winpty = ["alacritty_terminal/winpty"]
# Enabling this feature makes shaders automatically reload when changed