aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2020-12-24 01:28:41 +0300
committerGitHub <noreply@github.com>2020-12-23 22:28:41 +0000
commitfdc10d270e423e6bec756cab61b502e28260129e (patch)
treecb55f8cfb7776d861d50b7b3e5b2d165d3f38ce7 /alacritty/Cargo.toml
parentf19cbca9b4c98a33b786bd971e3abae66bd16e26 (diff)
downloadr-alacritty-fdc10d270e423e6bec756cab61b502e28260129e.tar.gz
r-alacritty-fdc10d270e423e6bec756cab61b502e28260129e.tar.bz2
r-alacritty-fdc10d270e423e6bec756cab61b502e28260129e.zip
Hide "missing" glyp for zerowidth character
This patch prevents missing zerowidth glyphs from obscuring the rendered glyph of a cell. The missing glyph itself is also consistently loaded and displayed on all platforms. It is initialized once together with the ascii symbols and then written to the atlas only once for every cached missing glyph. Co-authored-by: Christian Duerr <contact@christianduerr.com>
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index 4810ced4..f80e96c2 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -28,7 +28,7 @@ serde_json = "1"
glutin = { version = "0.26.0", default-features = false, features = ["serde"] }
notify = "4"
parking_lot = "0.11.0"
-crossfont = { version = "0.1.0", features = ["force_system_fontconfig"] }
+crossfont = { version = "0.2.0", features = ["force_system_fontconfig"] }
urlocator = "0.1.3"
copypasta = { version = "0.7.0", default-features = false }
libc = "0.2"