aboutsummaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 7b11c1e1..7dfa5b09 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -28,7 +28,6 @@ nix = "0.17.0"
signal-hook = { version = "0.1", features = ["mio-support"] }
[target.'cfg(windows)'.dependencies]
-winpty = { version = "0.2.0", optional = true }
mio-named-pipes = "0.1"
miow = "0.3"
winapi = { version = "0.3.7", features = [
@@ -37,6 +36,10 @@ winapi = { version = "0.3.7", features = [
]}
mio-anonymous-pipes = "0.1"
+# Winpty crate supports only MSVC.
+[target.'cfg(all(target_os="windows", target_env="msvc"))'.dependencies]
+winpty = { version = "0.2.0", optional = true }
+
[features]
default = ["winpty"]
bench = []