aboutsummaryrefslogtreecommitdiff
path: root/contrib/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/flake.nix')
-rw-r--r--contrib/flake.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/contrib/flake.nix b/contrib/flake.nix
index 57e56d0fdb..6355f3a68a 100644
--- a/contrib/flake.nix
+++ b/contrib/flake.nix
@@ -134,14 +134,16 @@
buildInputs = with pkgs;
oa.buildInputs ++ [
- cmake
lua.pkgs.luacheck
sumneko-lua-language-server
pythonEnv
include-what-you-use # for scripts/check-includes.py
jq # jq for scripts/vim-patch.sh -r
shellcheck # for `make shlint`
- doxygen # for script/gen_vimdoc.py
+ ];
+
+ nativeBuildInputs = with pkgs;
+ oa.nativeBuildInputs ++ [
clang-tools # for clangd to find the correct headers
];