aboutsummaryrefslogtreecommitdiff
path: root/alacritty/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2024-10-10 22:56:55 +0000
committerGitHub <noreply@github.com>2024-10-10 22:56:55 +0000
commit5dca7a85e7d8e98f8e770c17af8efb442c2277d0 (patch)
treead5e28f0458840e58adedde66a89ae71d3e7cae7 /alacritty/Cargo.toml
parentc032c89f1c457c3cf97dcda3f8367115fa5f66ea (diff)
downloadr-alacritty-5dca7a85e7d8e98f8e770c17af8efb442c2277d0.tar.gz
r-alacritty-5dca7a85e7d8e98f8e770c17af8efb442c2277d0.tar.bz2
r-alacritty-5dca7a85e7d8e98f8e770c17af8efb442c2277d0.zip
Add unicode 16 support
This fixes issues in width calculation for symbols added in Unicode version 16. Since the upstream unicode-width crate has not been updated yet, this makes use of the temporary unicode-width-16 version to support Unicode 16 with Alacritty 0.14.0.
Diffstat (limited to 'alacritty/Cargo.toml')
-rw-r--r--alacritty/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty/Cargo.toml b/alacritty/Cargo.toml
index ab44b046..81c186c9 100644
--- a/alacritty/Cargo.toml
+++ b/alacritty/Cargo.toml
@@ -40,7 +40,7 @@ serde_yaml = "0.9.25"
tempfile = "3.12.0"
toml = "0.8.2"
toml_edit = "0.22.21"
-unicode-width = "0.1"
+unicode-width = { package = "unicode-width-16", version = "0.1.0" }
winit = { version = "0.30.4", default-features = false, features = ["rwh_06", "serde"] }
[build-dependencies]