aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEisuke Kawashima <e.kawaschima+github@gmail.com>2024-12-10 09:10:27 +0900
committerGitHub <noreply@github.com>2024-12-09 16:10:27 -0800
commit1b90f4a9c472e674d707cbc01520423d305f6b17 (patch)
treef7a7f1c914bd9f1dfc3ec776bf332495d1bf7cee /CMakeLists.txt
parent3bb2d027597107a3d7f84ef61507104fd4dc050a (diff)
downloadrneovim-1b90f4a9c472e674d707cbc01520423d305f6b17.tar.gz
rneovim-1b90f4a9c472e674d707cbc01520423d305f6b17.tar.bz2
rneovim-1b90f4a9c472e674d707cbc01520423d305f6b17.zip
build: mark CMake variables advanced #31412
The variables are not marked as advanced, thus they appear in e.g. `ccmake`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9723de9176..ae5704cfe4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,6 +187,7 @@ if(NOT PREFER_LUA)
find_program(LUA_PRG NAMES luajit)
endif()
find_program(LUA_PRG NAMES lua5.1 lua5.2 lua)
+mark_as_advanced(LUA_PRG)
if(NOT LUA_PRG)
message(FATAL_ERROR "Failed to find a Lua 5.1-compatible interpreter")
endif()
@@ -200,6 +201,7 @@ message(STATUS "Using Lua interpreter: ${LUA_PRG}")
if(NOT LUA_GEN_PRG)
set(LUA_GEN_PRG "${LUA_PRG}" CACHE FILEPATH "Path to the lua used for code generation.")
endif()
+mark_as_advanced(LUA_GEN_PRG)
message(STATUS "Using Lua interpreter for code generation: ${LUA_GEN_PRG}")
option(COMPILE_LUA "Pre-compile Lua sources into bytecode (for sources that are included in the binary)" ON)
@@ -219,6 +221,7 @@ if(COMPILE_LUA AND NOT WIN32)
endif()
endif()
endif()
+mark_as_advanced(LUAC_PRG)
if(LUAC_PRG)
message(STATUS "Using Lua compiler: ${LUAC_PRG}")
endif()
@@ -229,7 +232,9 @@ if(CI_LINT)
set(LINT_REQUIRED "REQUIRED")
endif()
find_program(SHELLCHECK_PRG shellcheck ${LINT_REQUIRED})
+mark_as_advanced(SHELLCHECK_PRG)
find_program(STYLUA_PRG stylua ${LINT_REQUIRED})
+mark_as_advanced(STYLUA_PRG)
set(STYLUA_DIRS runtime scripts src test contrib)