aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordundargoc <gocdundar@gmail.com>2023-10-07 15:07:45 +0200
committerdundargoc <33953936+dundargoc@users.noreply.github.com>2023-11-05 21:39:12 +0100
commit397b92e02dbe7996a9da14aac73003fc8ddd1674 (patch)
tree542d6698545b8ba855bfec3f650eba152a19629d /CMakeLists.txt
parentacc646ad8fc3ef11fcc63b69f3d8484e4a91accd (diff)
downloadrneovim-397b92e02dbe7996a9da14aac73003fc8ddd1674.tar.gz
rneovim-397b92e02dbe7996a9da14aac73003fc8ddd1674.tar.bz2
rneovim-397b92e02dbe7996a9da14aac73003fc8ddd1674.zip
build: enable ASAN for MSVC
It is enabled with ENABLE_ASAN_UBSAN like other compilers. Technically it only enables ASAN as UBSAN is not available, meaning to make the variable names fully correct we'd need to separate it into two checks: ENABLE_ASAN and ENABLE_UBSAN, but the convenience of combining them into the same flag outweighs the theoretical correctness. Also note in CONTRIBUTING.md that debug builds in ASAN is not supported. Technically it is the debug runtime that is not supported, which cmake automatically enables when using the debug build type. However, neovim can't be built with debug builds without linking to the debug runtime since the third party libraries has likely been linked to the debug runtime if it was built with debug build type. This technicality is likely uninteresting to the potential developer and it's easier to just say to use a release build type.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a360c6043f..a7b7ef9c0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,12 +157,6 @@ if((ENABLE_ASAN_UBSAN AND ENABLE_MSAN)
message(FATAL_ERROR "Sanitizers cannot be enabled simultaneously")
endif()
-if(ENABLE_ASAN_UBSAN OR ENABLE_MSAN OR ENABLE_TSAN)
- if(NOT CMAKE_C_COMPILER_ID MATCHES "Clang" AND NOT CMAKE_C_COMPILER_ID MATCHES "GNU")
- message(FATAL_ERROR "Sanitizers are only supported for Clang and GCC")
- endif()
-endif()
-
# Place targets in bin/ or lib/ for all build configurations
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)