aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordundargoc <gocdundar@gmail.com>2023-11-24 13:28:15 +0100
committerdundargoc <33953936+dundargoc@users.noreply.github.com>2023-12-16 21:06:28 +0100
commit404fdb0f3683094c2d40e1ee7e41d5c491f41a06 (patch)
tree10902993f64a7e16d75217802d80eb8a091f0a49 /CMakeLists.txt
parent8fb7419d7c5e2df3b792d18fa56f973088e69be2 (diff)
downloadrneovim-404fdb0f3683094c2d40e1ee7e41d5c491f41a06.tar.gz
rneovim-404fdb0f3683094c2d40e1ee7e41d5c491f41a06.tar.bz2
rneovim-404fdb0f3683094c2d40e1ee7e41d5c491f41a06.zip
build: cmake fixes
- add EXTERNALPROJECT_OPTIONS variable to main build - use `REQUIRED` keyword for IWYU. - remove check_c_compiler_flag checks when `ENABLE_COMPILER_SUGGESTIONS` is `ON`. If we explicitly enable it then we probably want it to give an error if it doesn't exist, rather than silently skip it. - Move dependency interface libraries to their find module and use them as a pseudo-imported target. - Remove BUSTED_OUTPUT_TYPE. It's not used and we can reintroduce it again if something similar is needed. - Use LINK_OPTIONS intead of LINK_FLAGS when generating the `--version` output.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a314158edd..2672a275f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -282,24 +282,24 @@ endif()
ExternalProject_Add(uncrustify
URL https://github.com/uncrustify/uncrustify/archive/uncrustify-0.78.1.tar.gz
URL_HASH SHA256=ecaf4c0adca14c36dfffa30bc28e69865115ecd602c90eb16a8cddccb41caad2
- DOWNLOAD_NO_PROGRESS TRUE
DOWNLOAD_DIR ${DEPS_DOWNLOAD_DIR}/uncrustify
CMAKE_ARGS ${DEPS_CMAKE_ARGS}
CMAKE_CACHE_ARGS ${DEPS_CMAKE_CACHE_ARGS}
- EXCLUDE_FROM_ALL TRUE)
+ EXCLUDE_FROM_ALL TRUE
+ ${EXTERNALPROJECT_OPTIONS})
option(USE_BUNDLED_BUSTED "Use bundled busted" ON)
if(USE_BUNDLED_BUSTED)
ExternalProject_Add(lua-dev-deps
URL https://github.com/neovim/deps/raw/5a1f71cceb24990a0b15fd9a472a5f549f019248/opt/lua-dev-deps.tar.gz
URL_HASH SHA256=27db2495f5eddc7fc191701ec9b291486853530c6125609d3197d03481e8d5a2
- DOWNLOAD_NO_PROGRESS TRUE
DOWNLOAD_DIR ${DEPS_DOWNLOAD_DIR}/lua-dev-deps
SOURCE_DIR ${DEPS_SHARE_DIR}
CONFIGURE_COMMAND ""
BUILD_COMMAND ""
INSTALL_COMMAND ""
- EXCLUDE_FROM_ALL TRUE)
+ EXCLUDE_FROM_ALL TRUE
+ ${EXTERNALPROJECT_OPTIONS})
else()
add_custom_target(lua-dev-deps)
endif()