aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin M. Keyes <justinkz@gmail.com>2023-12-04 12:38:31 -0800
committerGitHub <noreply@github.com>2023-12-04 12:38:31 -0800
commit517f0cc634b985057da5b95cf4ad659ee456a77e (patch)
treebcf973c59c22b1b3d09b817b957d56e7892d2f86 /CMakeLists.txt
parente5d7003b02c9af96c51ea5638e07eea25057a216 (diff)
downloadrneovim-517f0cc634b985057da5b95cf4ad659ee456a77e.tar.gz
rneovim-517f0cc634b985057da5b95cf4ad659ee456a77e.tar.bz2
rneovim-517f0cc634b985057da5b95cf4ad659ee456a77e.zip
build: enable lintlua for scripts/ dir #26391
Problem: We don't enable stylua for many Lua scripts. Automating code-style is an important tool for reducing time spent on accidental (non-essential) complexity. Solution: - Enable lintlua for `scripts/` directory. - Specify `call_parentheses = "Input"`, we should allow kwargs-style function invocations.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6701b0211b..2bae668e51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,7 +233,7 @@ add_glob_target(
TARGET lintlua-stylua
COMMAND ${STYLUA_PRG}
FLAGS --color=always --check --respect-ignores
- GLOB_DIRS runtime/
+ GLOB_DIRS runtime/ scripts/
GLOB_PAT *.lua
TOUCH_STRATEGY SINGLE)
@@ -260,7 +260,7 @@ add_glob_target(
TARGET formatlua
COMMAND ${STYLUA_PRG}
FLAGS --respect-ignores
- GLOB_DIRS runtime
+ GLOB_DIRS runtime/ scripts/
GLOB_PAT *.lua)
add_custom_target(format)