aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin M. Keyes <justinkz@gmail.com>2024-04-30 04:30:21 -0700
committerGitHub <noreply@github.com>2024-04-30 04:30:21 -0700
commit71cf75f96a67aeb79ac3af6aa829bac81bd2d33d (patch)
treeb6582df55b2956fb2077f2d79c2cc7b6acf37c84 /CMakeLists.txt
parentefaf37a2b9450d56acbf48a44c3c791d00d70199 (diff)
downloadrneovim-71cf75f96a67aeb79ac3af6aa829bac81bd2d33d.tar.gz
rneovim-71cf75f96a67aeb79ac3af6aa829bac81bd2d33d.tar.bz2
rneovim-71cf75f96a67aeb79ac3af6aa829bac81bd2d33d.zip
docs: misc #24163
- Also delete old perl scripts which are not used since 8+ years ago. fix #23251 fix #27367 ref https://github.com/neovim/neovim/issues/2252#issuecomment-1902662577 Helped-by: Daniel Kongsgaard <dakongsgaard@gmail.com> Co-authored-by: Kevin Pham <keevan.pham@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ac1bd8b2b..797bbe7422 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,9 @@
# CMAKE REFERENCE
-# intro: https://codingnest.com/basic-cmake/
-# best practices (3.0+): https://gist.github.com/mbinna/c61dbb39bca0e4fb7d1f73b0d66a4fd1
-# pitfalls: https://izzys.casa/2019/02/everything-you-never-wanted-to-know-about-cmake/
+# - intro: https://codingnest.com/basic-cmake/
+# - best practices (3.0+): https://gist.github.com/mbinna/c61dbb39bca0e4fb7d1f73b0d66a4fd1
+# - pitfalls: https://izzys.casa/2019/02/everything-you-never-wanted-to-know-about-cmake/
+# - troubleshooting:
+# - variable_watch https://cmake.org/cmake/help/latest/command/variable_watch.html
# Version should match the tested CMAKE_URL in .github/workflows/build.yml.
cmake_minimum_required(VERSION 3.13)
@@ -167,6 +169,7 @@ endif()
option(ENABLE_ASAN_UBSAN "Enable Clang address & undefined behavior sanitizer for nvim binary." OFF)
option(ENABLE_MSAN "Enable Clang memory sanitizer for nvim binary." OFF)
+# TSAN exists to test Luv threads.
option(ENABLE_TSAN "Enable Clang thread sanitizer for nvim binary." OFF)
if((ENABLE_ASAN_UBSAN AND ENABLE_MSAN)