Commit message (Collapse) | Author | Age | |
---|---|---|---|
* | test: support upvalues in exec_lua | Lewis Russell | 2024-09-21 |
| | |||
* | test: improve test conventions | dundargoc | 2024-04-23 |
| | | | | | | | | | Specifically, functions that are run in the context of the test runner are put in module `test/testutil.lua` while the functions that are run in the context of the test session are put in `test/functional/testnvim.lua`. Closes https://github.com/neovim/neovim/issues/27004. | ||
* | refactor(lua): rename tbl_islist => islist | Justin M. Keyes | 2024-04-21 |
| | | | | ref #24572 | ||
* | refactor(test): inject after_each differently | Lewis Russell | 2024-04-10 |
| | |||
* | test: improve test conventions | dundargoc | 2024-04-08 |
| | | | | Work on https://github.com/neovim/neovim/issues/27004. | ||
* | refactor: format test/* | Justin M. Keyes | 2024-01-03 |
| | |||
* | fix(vim.mpack): rename pack/unpack => encode/decode #16175 | Justin M. Keyes | 2021-10-30 |
| | | | | | | | | | | | | | | | | | | | | | | | Problem: 1. "unpack" has an unrelated meaning in Lua: https://www.lua.org/manual/5.1/manual.html#pdf-unpack 2. We already have msgpackparse()/msgpackdump() and json_encode()/json_decode(), so introducing another name for the same thing is entropy. Solution: - Rename vim.mpack.pack/unpack => vim.mpack.encode/decode Caveat: This is incongruent with the `Unpacker` and `Packer` functions. - It's probably too invasive to rename those. - They also aren't part of our documented interface. - This commit is "reversible" in the sense that we can always revert it and add `vim.mpack.encode/decode` as _aliases_ to `vim.mpack.pack/unpack`, at any time in the future, if we want stricter fidelity with upstream libmpack. Meanwhile, `vim.mpack.encode/decode` is currently the total _documented_ interface of `vim.mpack`, so this change serves the purpose of consistent naming in the Nvim stdlib. | ||
* | feat(lua): make vim.mpack support vim.NIL and vim.empty_dict() | Björn Linse | 2021-09-09 |