aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f00937f0..590b9db0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,9 @@ AC_PROG_CC
AM_PROG_CC_C_O
AC_PROG_INSTALL
+# Default tmux.conf goes in /etc not ${prefix}/etc.
+test "$sysconfdir" = '${prefix}/etc' && sysconfdir=/etc
+
# Check for various headers. Alternatives included from compat.h.
AC_CHECK_HEADERS(
[ \
@@ -313,6 +316,13 @@ if test "x$found_strnvis" = xyes; then
fi
AM_CONDITIONAL(NO_VIS, [test "x$found_strnvis" = xno])
+# Look for cfmakeraw, compat/cfmakeraw.c used if missing.
+AC_CHECK_FUNC(cfmakeraw, found_cfmakeraw=yes, found_cfmakeraw=no)
+if test "x$found_cfmakeraw" = xyes; then
+ AC_DEFINE(HAVE_CFMAKERAW)
+fi
+AM_CONDITIONAL(NO_CFMAKERAW, [test "x$found_cfmakeraw" = xno])
+
# Look for getopt. glibc's getopt does not enforce argument order and the ways
# of making it do so are stupid, so just use our own instead.
AC_CHECK_FUNC(getopt, found_getopt=yes, found_getopt=no)
@@ -345,6 +355,7 @@ AC_CHECK_FUNCS(
dirfd \
setproctitle \
sysconf \
+ cfmakeraw \
]
)
@@ -416,6 +427,10 @@ else
AC_MSG_RESULT(no)
fi
+# Man page defaults to mdoc.
+MANFORMAT=mdoc
+AC_SUBST(MANFORMAT)
+
# Figure out the platform for osdep-*.c and forkpty-*.c.
AC_MSG_CHECKING(platform)
case "$host_os" in
@@ -455,6 +470,7 @@ case "$host_os" in
*solaris*)
AC_MSG_RESULT(sunos)
PLATFORM=sunos
+ MANFORMAT=man
;;
*hpux*)
AC_MSG_RESULT(hpux)