aboutsummaryrefslogtreecommitdiff
path: root/cmd-resize-pane.c
Commit message (Expand)AuthorAge
* Rename a member to match what it will be in future.nicm2021-08-21
* Add args parsing callback for some future work, currently unused.nicm2021-08-21
* Hide struct args behind a couple of accessor functions.nicm2021-08-20
* Fix some error strings, from Kris Katterjohn.nicm2020-05-25
* Drop having a separate type for style options and make them all strings,nicm2020-05-16
* Move cmdq_state into cmd-queue.c.nicm2020-04-13
* Rename cmdq_shared to cmdq_state which will better reflect what it isnicm2020-04-13
* Store a key event not a mouse event in the shared data.nicm2020-04-13
* Also move cmdq_item and cmdq_list into cmd-queue.c (this is to make itsnicm2020-04-13
* Make struct cmd local to cmd.c and move it out of tmux.h.nicm2020-04-13
* Add a -T flag to resize-pane to trim lines below the cursor, movingnicm2020-03-31
* Break code to convert an argument as a percentage into a common function.nicm2020-03-21
* Add support for percentage sizes for resize-pane ("-x 10%"). Also changenicm2019-10-15
* Correctly adjust mouse position if the status line is at the top andnicm2019-07-06
* Do not store the mouse position we calculate as the start of a drag backnicm2019-05-03
* Fix mouse positioning when the pane is not entirely visible.nicm2019-05-03
* Some tidying and helper functions.nicm2018-08-18
* Minor cosmetic improvement from KOIE Hidetaka.nicm2018-06-24
* Make it possible to resize multiple panes by dragging corners, from Dannicm2018-06-09
* Instead of working out which pane to resize with the mouse by walkingnicm2018-06-08
* Change how we resolve which pane is dragging when there are multiplenicm2017-05-11
* Get rid of the extra layer of flags and cmd_prepare() and just store thenicm2017-04-22
* Store state shared between multiple commands in the queue in a sharednicm2017-04-21
* Mass rename struct cmd_q to struct cmdq_item and related.nicm2016-10-16
* Rewrite command queue handling. Each client still has a command queue,nicm2016-10-16
* Add CMD_AFTERHOOK flag to the easy commands that don't need any special handl...nicm2016-10-14
* Add static in cmd-* and fix a few other nits.nicm2016-10-10
* Do not allow the opposite pane to resize when dragging with the mousenicm2016-10-10
* Remove some more unused variables, and use RB_FOREACH_SAFE innicm2016-03-01
* I no longer use my SourceForge address so replace it.nicm2016-01-19
* Instead of combined flags for -c, -s, -t, split into different setsnicm2015-12-14
* Use member names in cmd_entry definitions so I stop getting confusednicm2015-12-13
* Instead of every command resolving the target (-t or -s) itself, preparenicm2015-12-13
* Rewrite of tmux mouse support which was a mess. Instead of havingnicm2015-04-19
* Instead of setting up the default keys by building the key structnicm2014-10-20
* Remove the barely-used and unnecessary command check() function.nicm2013-10-10
* Add resize-pane -Z to temporary zoom the active pane to occupy the fullNicholas Marriott2013-03-24
* Add a command queue to standardize and simplify commands that call otherNicholas Marriott2013-03-24
* Add resize-pane -x and -y for absolute pane size (much requested).Nicholas Marriott2013-03-22
* Remove the layout undo/redo code which never really worked.Nicholas Marriott2013-01-17
* Make command exec functions return an enum rather than -1/0/1 values andNicholas Marriott2012-07-11
* Add a layout history which can be stepped through with select-layout -uNicholas Marriott2012-04-01
* Clean up and simplify tmux command argument parsing.Nicholas Marriott2011-01-04
* Massive spaces->tabs and trailing whitespace cleanup, hopefully for the lastNicholas Marriott2009-12-03
* Get rid of the ugly CMD_CHFLAG macro and use a const string (eg "dDU") in theNicholas Marriott2009-11-13
* Merge pane number into the target specification for pane commands. Instead ofNicholas Marriott2009-07-30
* Make all messages sent between the client and server fixed size.Nicholas Marriott2009-07-26
* Tidy up keys: use an enum for the key codes, and remove the macros which justNicholas Marriott2009-07-21
* Improved layout code.Nicholas Marriott2009-07-19
* Having fixed flags for single-character getopt options is a bit hard toNicholas Marriott2009-07-13